Saturday, September 24, 2011

"Qt version uses an unsupported makefile generator (used: MSBUILD, supported: MSVC.NET)"

Ok, this post is for those who build Qt libraries with Visual C++ and annoyed by this:
"This Qt version uses an unsupported makefile generator (used: MSBUILD, supported: MSVC.NET)"

It may happen when adding your newly built Qt version in Qt Visual Studio Add-in.

Here's a little hack that works for me:
  1. Close Visual Studio.
  2. Run regedit.
  3. Hop to HKEY_CURRENT_USER\Software\Trolltech\Versions
  4. Add a new key named "4.7.4" or whatever version you have.
  5. Under the new key, create a new string "InstallDir" valued with "c:\Qt\4.7.4":
  6. Run Visual Studio
  7. Click Qt -> Qt Options.
  8. The new version should be there.

My particular system:
  • Visual Studio 2010 with SP1
  • Qt 4.7.4 - Instruction to build with Visual Studio 2010 is here
  • Qt Visual Studio Add-in 1.1.9


7 comments:

  1. Prayer is not asking. It is a longing of the soul. It is daily admission of one's weakness. It is better in prayer to have a heart without words than words without a heart. See the link below for more info.

    #asking
    www.matreyastudios.com

    ReplyDelete
  2. Awesome there, Great work, keep it up. I love returning back to this site and reading the quality content you always have on offer.

    kieth
    www.gofastek.com

    ReplyDelete
  3. Awesome there, Great work, keep it up. I love returning back to this site and reading the quality content you always have on offer.

    kieth
    www.gofastek.com

    ReplyDelete
  4. I did this but still I can't use include Qapplication on my project

    ReplyDelete
  5. Thank you for posting some kind of information. It was really helpful since I am doing some research now.

    www.imarksweb.org

    ReplyDelete